讓XP遠端桌面支援VISTA網路層級驗證

rdt_0

VISTA遠端桌面有兩種模式可以選,
一個使用網路層級驗證(比較安全吧)但只能用VISTA連線,
一個相容XP模式(不使用網路層級驗證)
看起來當然是要選擇安全的模式跑~

不過這一選來,如果用XP遠端連VISTA就會出現上面訊息,(遠端電腦需要網路層級驗證,但您的電腦不支援)
看起來似乎宣判死刑,不過如果您的XP有升級SP3那就有救了

rdt_1
首先打開遠多桌面,在左上方右鍵關於 看一下 真的不支援網路層級認證

接下來 開始/執行/regedit (懶得自己弄這邊有我弄好的,請另存連結再執行)
編輯 [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlLsa] 內的Security Packages
加入一行tspkg (原本很多行,請再加入這一行)
再編輯 [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSecurityProviders]的SecurityProviders
最後面再加入 , credssp.dll (原本是msapsspc.dll, schannel.dll, digest.dll, msnsspc.dll)

rdt_2

好了之後新啟動遠端桌面 看一下關於
恭喜,您的XP可以活更久了~科科